Scheduled report emails are successfully delivered when the total number of attachments is three or fewer. However, when the report generates four attachments, the email is never received by the recipient.
Checked the error log:
SendGrid.Helpers.Errors.Model.BadRequestException: {"ErrorHttpStatusCode":400,"ErrorReasonPhrase":"Bad Request","SendGridErrorMessage":"max content-length exceeded of: 31457280 bytes","FieldWithError":null,"HelpLink":null}
This issue occurs because the attachments' size exceeded the email provider email size limit (30mb). This is the general limit when sending emails. You will need to split the attachments between multiple emails as this limit will not change; recipient email server will not accept the email attachments that breach the size limit.
